[odb-users] odb compiler error: The system cannot find the path specified

msalihcaliskan msalihcaliskan at gmail.com
Mon Oct 26 16:46:50 EDT 2015

Hello Boris,

Thank you for your prompt reply,

Yes, shame on me. I totaly misunderstood the warning that mentioned in the
README and merged the odb compiler folders with my mingw environment. When
I reset the content and used full path for odb compiler, everything works.

Thank you again.

2015-10-26 18:00 GMT+02:00 Boris Kolpackov <boris at codesynthesis.com>:

> Hi,
> Mehmet Salih Çalışkan <msalihcaliskan at gmail.com> writes:
> > I can run "odb --version" without an error however, when I run "odb
> > -d sqlite --generate-query --generate-schema person.hxx" command in
> > "hello" sample folder from mingw command prompt, I get an error as
> > below:
> >
> > "odb.exe: error: The system cannot find the path specified."
> My guess is that you copied/moved odb.exe somewhere. If you have,
> shame on you; the README file explicitly tells you not to:
> "Note also that while you can move the ODB compiler directory around,
> you cannot move the individual sub-directories or files inside it. For
> example, copying the ODB compiler executable to C:\Windows will not
> work."
> If you haven't copied/moved odb.exe, then could you run this test for
> me:
> 1. Unpack ODB to c:/
> 2. From your MinGW shell, run the command line that produces the error
>    but using the absolute ODB compiler path, e.g.,
>    /c/odb-2.4.0-i686-linux-gnu/bin/odb -d sqlite ...
> 3. If that still doesn't work, start the MinGW shell that comes with
>    the ODB compiler:
>    /c/odb-2.4.0-i686-linux-gnu/mingw/msys.bat
>    And try the same command line as in step #2 above.
> Boris

More information about the odb-users mailing list