[odb-users] Unresolved inclusion: mysql/mysqld_error.h

Dan Coffey dcoffey at netharmonix.com
Thu Jul 14 11:06:35 EDT 2011

Hi Boris,

Thanks for the direction.  I'm trying to run the configure command in 
the /opt/libodb-mysql directory
$ *sh ./configure*

I'm using Cygwin on XP and I created:
symbolic links to the files
ln -s 
ln -s /cygdrive/d/Development/C++/ODB/odb-1.4.0-i686-windows/mingw/lib 

ln -s /cygdrive/d/Development/C++/ODB/odb-mysql-1.4.0 /opt/libodb-mysql

symbolic links to the files:
ln -s /cygdrive/d/Development/C++/DB/mysql-5.5.14.win32 /usr/local/mysql
I copied and changed:  mysqlclient.lib to mysqlclient_r.a

When I run /opt/libodb-mysql/configure
I get an error:
*/configure: error: cannot run /bin/sh config/config.sub/*

I tried to go directly to the D:PATH, but that had the same error.

I also ran it with:
$ sh -xv ./configure
Here is the end of that output

Thanks for you help.


On 7/14/2011 6:04 AM, Boris Kolpackov wrote:
> Hi Dan,
> Dan Coffey<dcoffey at netharmonix.com>  writes:
>> This statement in mysql-types.hxx seems to be the cause, is there some
>> place I need to configure so that this attribute
> This macro is defined in the config.h file in libodb-mysql in
> odb/mysql/details/ which, according to your email you don't have.
> This tells me that you haven't built the libodb-mysql runtime.
> Before you can build any examples, you need to build libodb and
> libodb-mysql.
> To build libodb-mysql for MinGW you will need the MySQL client
> library. You can use the headers and the library that came with
> the MySQL package, however, you will need to rename libmysql.lib
> to libmysqlclient_r.a. I also suggest that you get rid of spaces
> in your paths; it will make your life much easier.
> Boris

More information about the odb-users mailing list