[odb-users] Dependency issue with build2 0.12 and odb 2.5

Vincent chere.loque at gmail.com
Fri Nov 22 09:10:43 EST 2019


I am facing a dependency issue when building odb beta 2.5 with build2
0.12.0. Everything worked correctly with build2 0.11.0, until I upgraded
to build2 0.12.0, which was required since I started to get this error 2
days ago:

   + bpkg-stage --fetch-timeout 600 build --for install --yes --plan=
build2 bpkg bdep
   error: unable to satisfy constraint (build2 >= 0.12.0) for package build2
     info: available build2 version is 0.11.0
   info: while satisfying build2/0.12.0

Installed build2 like this:

   $ build2.sh --uninstall --yes
   $ curl -o build2.sh -sSfO
   $ shasum -a 256 -b build2.sh
   $ sh build2.sh --no-check --trust yes --yes

   About to download, build, and install build2 toolchain 0.12.0 (public).

   From:  https://download.build2.org
   Using: g++-8
   Successfully installed build2 toolchain 0.12.0 (public).

Then, tried to install odb beta (2.5.0-b.17) :

   $ bpkg create -d odb-build2/ cc config.cxx=g++ config.cc.coptions=-O3
config.bin.rpath=my/local/lib/ config.install.root=my/local --wipe
   $ cd odb-build2/
   $ bpkg build --yes --trust-yes odb at https://pkg.cppget.org/1/beta
   fetching pkg:cppget.org/beta
   fetching pkg:cppget.org/testing (complements pkg:cppget.org/beta)
   fetching pkg:cppget.org/stable (complements pkg:cppget.org/testing)
   error: unable to satisfy constraint (build2 >= 0.11.0) for package odb
      info: available build2 version is 0.10.0
   info: while satisfying odb/2.5.0-b.17

Also tried with "/1/alpha" without success.

Thank you for your assistance!


More information about the odb-users mailing list