[odb-users] simple app

dd durga.disc at gmail.com
Tue Aug 27 09:42:04 EDT 2013

I tried to compile hello world example. I am facing the below issues:

user at username:~/ODB/tests/howtouse1$ odb -d sqlite --generate-query person.h
In file included from
                 from <standard-odb-prologue>:7:
/usr/include/features.h:324:26: fatal error: bits/predefs.h: No such file
or directory
compilation terminated.

I want to create helloworld program with odb framework. I completely messed

On Tue, Aug 27, 2013 at 3:14 PM, dd <durga.disc at gmail.com> wrote:

> Thanks for quick reply.
> I am able to build libodb and libodb-sqlite-2.2.2.
> user at username:~/ODB/odb-examples$ ./configure --with-database sqlite
> configure: WARNING: you should use --build, --host, --target
> checking for a BSD-compatible install... /usr/bin/install -c
> checking whether build environment is sane... yes
> checking for a thread-safe mkdir -p... /bin/mkdir -p
> checking for gawk... gawk
> checking whether make sets $(MAKE)... yes
> checking how to create a ustar tar archive... gnutar
> checking for style of include used by make... GNU
> checking for sqlite-gcc... no
> checking for gcc... gcc
> checking whether the C compiler works... yes
> checking for C compiler default output file name... a.out
> checking for suffix of executables...
> checking whether we are cross compiling... no
> checking for suffix of object files... o
> checking whether we are using the GNU C compiler... yes
> checking whether gcc accepts -g... yes
> checking for gcc option to accept ISO C89... none needed
> checking dependency style of gcc... gcc3
> checking for sqlite-ar... no
> checking for sqlite-lib... no
> checking for sqlite-link... no
> checking for ar... ar
> checking the archiver (ar) interface... ar
> checking build system type... Invalid configuration `sqlite': machine
> `sqlite' not recognized
> *configure: error: /bin/bash config/config.sub sqlite failed*
> I tried with sqlite and sqlite3. But, it's throwing configuration error.
> How to resolve this?
> On Tue, Aug 27, 2013 at 3:04 PM, Boris Kolpackov <boris at codesynthesis.com>wrote:
>> Hi,
>> dd <durga.disc at gmail.com> writes:
>> >   When I try to libodb, it's throwing *below errors*:
>> >
>> > user at username:~/ODB/libodb$ make
>> > Making all in odb
>> > make[1]: Entering directory `/home/user/ODB/libodb/odb'
>> > make  all-am
>> > make[2]: Entering directory `/home/user/ODB/libodb/odb'
>> > make[2]: Leaving directory `/home/user/ODB/libodb/odb'
>> > make[1]: Leaving directory `/home/user/ODB/libodb/odb'
>> > make[1]: Entering directory `/home/user/ODB/libodb'
>> > make[1]: Nothing to be done for `all-am'.
>> > make[1]: Leaving directory `/home/user/ODB/libodb'
>> I don't see any errors. Everything seems to have been built
>> successfully. Next run:
>> sudo make install
>> As instructed in the guide.
>> Boris

More information about the odb-users mailing list