[odb-users] Re: Problem loading long TEXT strings with MySQL

Andreas Gerasch gerasch at informatik.uni-tuebingen.de
Fri Feb 10 04:46:07 EST 2012

Hi Boris,

I just tried the 1.8.0 version (including libodb libodb-mysql 
libodb-boost odb) but I have the same Problem.

Below are the version infos about libmysqlclient-dev and the 
dependencies of driver.

The mysql server has version 5.1.41-3ubuntu12.10 (Ubuntu) and it is 
running on the same machine.

What is your version of the libmysqlclient-dev?


 > dpkg -s libmysqlclient-dev
Package: libmysqlclient-dev
Status: install ok installed
Priority: optional
Section: libdevel
Installed-Size: 9580
Maintainer: Ubuntu Developers <ubuntu-devel-discuss at lists.ubuntu.com>
Architecture: amd64
Source: mysql-dfsg-5.1
Version: 5.1.41-3ubuntu12.10
Replaces: libmysqlclient15-dev
Provides: libmysqlclient15-dev
Depends: libmysqlclient16 (= 5.1.41-3ubuntu12.10), zlib1g-dev, libc6 (>= 
2.2.5), libgcc1 (>= 1:4.1.1), libstdc++6 (>= 4.1.1)
Conflicts: libmysqlclient10-dev, libmysqlclient12-dev, 
libmysqlclient14-dev, libmysqlclient15-dev
Description: MySQL database development files
  MySQL is a fast, stable and true multi-user, multi-threaded SQL database
  server. SQL (Structured Query Language) is the most popular database query
  language in the world. The main goals of MySQL are speed, robustness and
  ease of use.
  This package includes development libraries and header files.
Homepage: http://dev.mysql.com/
Original-Maintainer: Debian MySQL Maintainers 
<pkg-mysql-maint at lists.alioth.debian.org>

 > ldd driver
linux-vdso.so.1 =>  (0x00007fffc3dff000)
libodb-mysql-1.8.so => /usr/local/lib/libodb-mysql-1.8.so 
libQtCore.so.4 => /usr/lib/libQtCore.so.4 (0x00007f4e35266000)
libodb-boost-1.8.so => /usr/local/lib/libodb-boost-1.8.so 
libboost_date_time.so.1.40.0 => /usr/lib/libboost_date_time.so.1.40.0 
libboost_system.so.1.40.0 => /usr/lib/libboost_system.so.1.40.0 
libodb-1.8.so => /usr/local/lib/libodb-1.8.so (0x00007f4e34a3b000)
libpthread.so.0 => /lib/libpthread.so.0 (0x00007f4e3481e000)
libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x00007f4e3450a000)
libm.so.6 => /lib/libm.so.6 (0x00007f4e34286000)
libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x00007f4e3406f000)
libc.so.6 => /lib/libc.so.6 (0x00007f4e33cec000)
libmysqlclient_r.so.16 => /usr/lib/libmysqlclient_r.so.16 
libz.so.1 => /lib/libz.so.1 (0x00007f4e336bf000)
libdl.so.2 => /lib/libdl.so.2 (0x00007f4e334bb000)
libgthread-2.0.so.0 => /usr/lib/libgthread-2.0.so.0 (0x00007f4e332b5000)
librt.so.1 => /lib/librt.so.1 (0x00007f4e330ad000)
libglib-2.0.so.0 => /lib/libglib-2.0.so.0 (0x00007f4e32dcf000)
/lib64/ld-linux-x86-64.so.2 (0x00007f4e3593e000)
libcrypt.so.1 => /lib/libcrypt.so.1 (0x00007f4e32b95000)
libnsl.so.1 => /lib/libnsl.so.1 (0x00007f4e3297b000)
libpcre.so.3 => /lib/libpcre.so.3 (0x00007f4e3274c000)

On 02/10/2012 10:07 AM, Boris Kolpackov wrote:
> Hi Andreas,
> Andreas Gerasch<gerasch at informatik.uni-tuebingen.de>  writes:
>> After using the odb-examples.tar.gz, I was able to reproduce the problem
>> using your hello example by introducing a vector of middle names.
> I tried the code you have attached with ODB 1.8.0 and it works without
> any problems. I don't have the 1.7.0 build around, so could you try
> this test with 1.8.0 on your setup? While I don't believe we fixed this
> specific issue in 1.8.0, we might have made some changes that fixed it
> indirectly.
> If it still fails for you with 1.8.0, I will need more information about
> your setup. Specifically, which version of the MySQL client library you
> are using (dpkg -s libmysqlclient-dev) as well as the version of the
> MySQL server you are connecting to.
> Boris
-------------- next part --------------
A non-text attachment was scrubbed...
Name: gerasch.vcf
Type: text/x-vcard
Size: 435 bytes
Desc: not available
Url : http://codesynthesis.com/pipermail/odb-users/attachments/20120210/51c5404f/gerasch.vcf

More information about the odb-users mailing list