[odb-users] Re: Problem loading long TEXT strings with MySQL

Boris Kolpackov boris at codesynthesis.com
Thu Feb 9 10:17:56 EST 2012

Hi Andreas,

In the future please keep your replies CC'ed to the odb-users mailing
list, again, as discussed in the posting guidelines:


Andreas Gerasch <gerasch at informatik.uni-tuebingen.de> writes:

> I tried to compile your examples, but the bootstrap and the configure  
> aborts with errors:
> ./bootstrap
> [...]
> configure.ac:11: installing `config/missing'
> automake: no `Makefile.am' found for any configure output
> automake: Did you forget AC_CONFIG_FILES([Makefile]) in configure.ac?
> autoreconf: automake failed with exit status: 1
> ./configure --with-database=mysql
> [...]
> configure: creating ./config.status
> ./config.status: eval: line 1178: syntax error near unexpected token `('
> ./config.status: eval: line 1178: `set X   :F  __path__(config_files) :H  
> config.h    :C  depfiles libtool mysql.options'
> ./config.status: line 1178: warning: syntax errors in . or eval will  
> cause future versions of the shell to abort as Posix requires
> Any ideas? I use ubuntu lucid and used the head from your examples git.

You cannot just get a project from git and bootstrap it. You first need
to prepare the distribution (see the INSTALL-GIT file for details). It
is much easier, however, to get the official odb-examples-1.7.0.tar.bz2
package which is already bootstrapped. Older releases are available here:


I just tried to change the line 31 in hello/driver.cxx:

person jane ("Jane", "Doe", 32);

To read:

person jane ("Jan" + string (512, 'n') + 'e', "Doe", 32);

I then ran the test (make check) and I see the correct, full string
being printed. Can you try this and see if it works for you?


More information about the odb-users mailing list