[odb-users] Qt BLOB Support

Boris Kolpackov boris at codesynthesis.com
Fri Oct 28 02:42:28 EDT 2011

Hi Pascal,

In the future please keep your replies CC'ed to the odb-users mailing
list as discussed in the posting guidelines:


Pascal Stoll <past0004 at stud.fh-kl.de> writes:

> Windows 7 Professional
> Visual Studio Professional 2008
> XAMPP 1.7.7 {
>     Apache 2.2.21
>     MySQL 5.5.16
>     PHP 5.3.8
>     phpMyAdmin 3.4.5
>     FileZilla FTP Server 0.9.39
>     Tomcat 7.0.21 (with mod_proxy_ajp as connector)
> }
> Qt 4.5.3 (i used the libs which where included with Maya2008)
> Boost 1.43.0

I assume you are using ODB 1.6.0, correct? I also assume you ran
ODB with the -p qt (or --profile qt) option.

> One thing is, i had to bind odb_mysql against a normal mysql server
> installation, because the libs from xampp weren't working. It was
> MySQL Community Server 5.5.17

Can you be more specific? What exactly didn't work?

In any case I tried to reproduce this without any luck. I tried all of
these combinations:

5.1 client libs -> 5.1 server
5.1 client libs -> 5.5 server
5.5 client libs -> 5.1 server
5.5 client libs -> 5.5 server

Everything works without any issues. All the tests in the test suite pass,
including the one that checks the QByteArray to BLOB mapping.

At this point I would need your help to try and figure out what's going
on. Can you run the test we talked about earlier under the VC++ debugger
and set a breakpoint in libodb-qt/odb/qt/basic/mysql/qbyte-array-traits.hxx
inside the set_value() function. In particular, can you check the values
of the 'is_null' and 'n' arguments? The first one should be false and the
second should be the number of bytes in the BLOB.


More information about the odb-users mailing list