[odb-users] ODB 2.5.0

Kingle Zhuang kingle.zhuang at ringcentral.com
Wed May 29 02:21:21 EDT 2019

Now I know how to fix build2 installation issues.
1. First can not use mac build-in openssl, should install openssl 1.1 or 1.0 through third party tools like homebrew
2. copy openssl to /usr/local/bin, copy include files to /usr/local/include, copy lib files to /usr/local/lib
3. sh build2-install-0.10.0.sh -j 1, else failure on some machines due to display 'can not execute clang++: too many open files'

On 5/29/19, 8:09 AM, "Kingle Zhuang" <kingle.zhuang at ringcentral.com> wrote:

    Thank you for your reply.
    For 2, I suggest we can use int64_t instead of long long int when build on 64 bit platform.
    Attachment is error log when build 64 bit for android
    By the way, I installed build2 according to the documentation[https://build2.org/install.xhtml]. I tried two mac[10.14.4] machines that were not installed successfully, so I can't use the build2 tool. I tried 0.10 and 0.9.
    On 5/28/19, 10:55 PM, "Boris Kolpackov" <boris at codesynthesis.com> wrote:
        Kingle Zhuang <kingle.zhuang at ringcentral.com> writes:
        >   1.  When will the 2.5.0 version can be official released?
        While the release is overdue we don't yet have a firm date.
        The reason for the delay is that we are moving to a uniform
        build/packaging toolchain as well as more of "continuous 
        delivery" model in the future. I would recommend that you
        do not wait for the official release and start using the
        new setup as described here:
        At this stage in the development cycle, it is as stable as 2.4.0,
        we are using it ourselves in multiple projects, we have migrated
        a number of users with very good results, and it is fully supported
        (i.e., we provide the same level of support as for 2.4.0).
        >   2.  For android arm64-v8a support, int64_t is type defined to long on
        >       android ndk, and odb compiler only generate long long int for int64_t,
        >       so when we use std::vector<int64_t> for field, odb compiler will
        >       generate std::vector<long long int> for that, finally cause compiler
        >       error when build 64bit app. So my question is that ‘Is it fix on
        >       2.5.0?’
        I am guessing you are generating the database support code on Linux
        and then compiling it for the Android target. If that's the case, then
        yes, chances are this could be fixed in 2.5.0 since we've done some
        extra work on using aliases instead of the underlying types (it is still
        not always possible). So I would suggest that you try 2.5.0 and see how
        it goes.

More information about the odb-users mailing list