[odb-users] compiling error

Boris Kolpackov boris at codesynthesis.com
Tue Aug 14 09:00:58 EDT 2012


yb947835908 at gmail.com writes:

> And I encounter with this problem: While compiling the mapping example,
> it says: (traits.hxx':error:unable to open in read mode).
> What dose that mean and how can I solve this?
> On the other hand, I tried to remove the (--hxx-prologue '#include
> "traits.hxx"' ) option while compiling and manually added text (#include
> "traits.hxx") into the generated file person-odb.hxx , it worked  just well.

The command line in the README was not valid for Windows (I've fixed
that). Try this variant instead, which works for both POSIX and Windows

--hxx-prologue "#include \"traits.hxx\""

> By the way, there is a tiny error: in the file 
> \odb-examples-2.0.0\c++11\README, you miss a '-' in the command
> line, that is, it should be "odb ... --std c++11..." , not  "odb ... -std
> c++11...".

Fixed. Thanks for reposting this!


More information about the odb-users mailing list